아수스 R564DA-BQ774 노트북에 리눅스 민트 20 XFCE 설치 리눅스


최근에 구입한 아수스(ASUS) 비보북(Vivobook) R564DA-BQ774에 리눅스 민트(Linux Mint) 20 XFCE를 설치했다. 5월에 구입했으나 코로나바이러스 문제로 배송이 늦어져서 6월말에야 받았다.

R564DA-BQ774의 하드웨어 사양은 아래와 같다.

AMD 라이젠(Ryzen) 5 3500U 쿼드코어 APU
8GB RAM
512GB NVMe M.2 SSD

바이오스(BIOS) 설정을 먼저 살펴 보았다. 전원을 켜고 F2를 누르면 바이오스로 들어간다. 바이오스 정보를 보니 X512DA라고 되어 있다. X512DA가 이전에 나온 모델인데, R564DA도 같은 바이오스를 사용하는 모양이다.

어쨌든, 바이오스의 설정을 보니 예전 방식(legacy boot)을 지원하지 않고 UEFI 부팅만 지원한다. YUMI UEFI(관련 내용은 이전게시물을 참고하자. 여기로)를 이용해서 UEFI 부팅 USB메모리를 만들어서 진행했다.
 
리눅스 민트 20은 우분투 20.04LTS를 기반으로 하고 있어서 최신 하드웨어에 대한 지원도 나쁘지 않을 것이라 기대하며 라이브 세션(live session)으로 부팅을 해 보니, 별도의 드라이버를 설치하지 않고 큰 문제 없이 하드웨어가 인식되는 것 같다. 무선랜도 곧바로 사용 가능했다.

설치를 완료하고 인터넷을 바로 사용할 수 있어서 한글 입력 기능도 곧바로 설치했다(리눅스 민트 20의 한글 입력 기능 설치는 이전 게시물을 참고하자. 여기로).

큰 무리 없이 잘 사용하고 있었는데, 한가지 심각한 문제를 발견했다. AC 전원을 연결한 상태일 때는 모든 동작이 다 정상인 것 같았는데, AC 전원을 끊고 배터리로 동작하는 상태에서는 부팅이 제대로 되지 않는다.

처음 전원을 켤 때는 정상적으로 부팅이 되는 듯하다가 로그인 화면이 나오지 않고 검은 화면에서 더 이상 진행되지 않았다. 처음에는 이것이 무슨 이유인지 모르고 한참을 헤맸는데, 이리 저리 시험을 하다 보니 AC 전원이 없을 때만 이런 현상이 나타나는 것으로 판명.

라이젠 APU에 대한 드라이버 지원이 아직 안정화되지 않은 것으로 의심되어 커널(kernel)을 업데이트해 보기로 했다. 리눅스 민트 20 XFCE의 커널 버전은 5.4인데, 최신 버전인 5.7.6으로 업데이트를 진행했다.

커널 업그레이드는 우분투 커널 업데이트 스크립트(ubuntu-mainline-kernel.sh)를 이용했다. (관련 내용은 이전 게시물을 참고하자. 여기로)

스크립트를 다운로드한 후에 터미널창에서 아래와 같이 작업했다.

# 커널 5.7.6 설치
sudo bash ubuntu-mainline-kernel -i 5.7.6

# 설치 완료후 재기동
sudo init 6

커널을 5.7.6으로 바꾸고 나니, AC 전원이 연결되지 않아도 부팅에 문제가 없다. 이제서야 별 문제 없이 잘 굴러간다. 일단 이 상태로 사용해 보기로.



핑백

덧글

  • 채널 2nd™ 2020/07/06 04:30 # 답글

    이 정도 스펙이면 넘나 훌륭한데 -- 메모리가 8 GB고, 하드가 512 GB면.. 날라 댕길 듯.

    (아, 내가, ATOM 유저다~)
  • 반달가면 2020/07/06 16:33 #

    일단 쾌적하게 잘 사용중입니다. 메모리 8GB중에 2GB는 VRAM으로 들어가고 실사용 범위는 6GB 정도네요.
댓글 입력 영역
* 비로그인 덧글의 IP 전체보기를 설정한 이글루입니다.

Google Analytics


B-Side


adsense(w160_h600)2

통계 위젯 (화이트)

40736
3890
2062946

adsense(w160_h600)_3

2019 대표이글루_IT